欢迎访问 水平网    今天是:2017年11月19日 注册 | 登录 | 订阅 | 收藏
>> 网络技术 >> 路由交换 >> H3C MSR系列路由器BGP路由协议基础配置
推荐文章
热点文章
专题
JQuery框架
Prototype.js
HTML5

H3C MSR系列路由器BGP路由协议基础配置

作者:未知,  来源:网络,  阅读:1565,  发布时间:2014-07-01 【放入收藏夹
一、组网需求:
RouterA和RouterB之间运行IBGP,Router B和Router C之间运行EBGP。

设备清单:PC两台、MSR系列路由器3台

二、组网图:


三、配置步骤:
选用设备和版本:MSR系列、Version 5.20, Beta 1105。
以下为Router A 配置: //配置router id和loopback 0 接口地址一样
#
router-id 1.1.1.1
#
//配置loopback0接口地址
interface GigabitEthernet0/0
ip address 20.2.2.1 255.255.255.252
#
interface GigabitEthernet0/1
ip address 10.1.1.1 255.255.255.0
#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
#
//启动BGP,AS为100
bgp 100
undo synchronization
//将路由表中10.1.1.0/24网段路由发布出去
network 10.1.1.0 255.255.255.0
//配置组“in”,类型为internal
group in internal
//指定IBGP邻居
peer 2.2.2.2 group in
//使用loopback0建立IBGP连接
peer in connect-interface LoopBack0
#
//静态路由保证内部各网段地址互通,可以使用OSPF/ISIS/RIP等IGP替代
ip route-static 2.2.2.2 255.255.255.255 20.2.2.2
#

以下为Router B 配置: #
router-id 2.2.2.2
#
interface GigabitEthernet0/0
ip address 20.2.2.2 255.255.255.252
#
interface GigabitEthernet0/1
ip address 30.3.3.1 255.255.255.252
#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
#
//启动BGP,AS为100
bgp 100
undo synchronization
//配置组“in”,类型为internal
group in internal
//指定IBGP邻居
peer 1.1.1.1 group in
//从EBGP学到路由向IBGP扩散时将下一跳改成自己的地址
peer in next-hop-local
//使用loopback0建立IBGP连接
peer in connect-interface LoopBack0
//配置组“ex”,类型为external
group ex external
//指定EBGP邻居
peer 30.3.3.2 group ex as-number 200
#
//静态路由保证内部各网段地址互通,可以使用OSPF/ISIS/RIP等IGP替代
ip route-static 1.1.1.1 255.255.255.255 20.2.2.1
#

以下为Router C 配置: #
router-id 3.3.3.3
#
interface GigabitEthernet0/0
ip address 30.3.3.2 255.255.255.252
#
interface GigabitEthernet0/1
ip address 40.4.4.1 255.255.255.0
#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
#
//启动BGP,AS为200
bgp 200
undo synchronization
//发布路由表中40.4.4.0/24网段路由
network 40.4.4.0 255.255.255.0
//配置组“ex”,类型为external
group ex external
//指定EBGP邻居
peer 30.3.3.1 group ex as-number 100
#

四、配置关键点:
1)Router id 最好配置成和loopback接口地址相同。若没有手工指定router id ,路由器会从当前接口的IP地址中自动选择一个。
2)配置BGP邻居时候要注意是IBGP邻居还是EBGP邻居。
3)此例仅演示IBGP和EBGP最简配置,实际组网中,路由器间可以正常建立TCP连接就可以建立IBGP邻居关系,EBGP缺省必须是逐跳之间建立连接,即使用同一链路上的地址建立连接。
TGAS:H3CMSR路由器BGP协议
评论【共有0条评论】查看所有评论
称呼:(*)   邮箱:   QQ:   验证码: 看不清楚?点击刷新验证码