欢迎访问 水平网    今天是:2017年11月19日 注册 | 登录 | 订阅 | 收藏
>> 网络技术 >> 路由交换 >> H3C AR28/AR46系列路由器BGP路由反射器典型配置
推荐文章
热点文章
专题
JQuery框架
Prototype.js
HTML5

H3C AR28/AR46系列路由器BGP路由反射器典型配置

作者:未知,  来源:网络,  阅读:1678,  发布时间:2014-07-01 【放入收藏夹

【需求】
RouterA,RouterB,RouterC为AS 100,其中RotuerB为路由反射器(RR)。

【组网图】

 

以下为RouterA配置脚本: #
sysname RouterA
#
router id 1.1.1.1 /配置router id和loopback0地址一致/
#
radius scheme system
#
domain system
#
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
#
interface Serial0/0
link-protocol ppp
ip address 20.1.1.1 255.255.255.252
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
bgp 100 /配置BGP,AS为100/
undo synchronization /配置非同步/
group in internal /配置组’in’/
peer in connect-interface LoopBack0
peer 1.1.1.2 group in /指定iBGP邻居/
#

 

ospf 1
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 20.1.1.0 0.0.0.3
#
user-interface con 0
user-interface vty 0 4
#
return

以下为RouterB置脚本: #
sysname RouterB
#
router id 1.1.1.2 /配置router id和loopback0地址一致/
#
radius scheme system
#
domain system
#
interface Seria0/0
link-protocol ppp
ip address 20.1.1.2 255.255.255.252
#
interface Serial0/1
link-protocol ppp
ip address 30.1.1.1 255.255.255.252
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.2 255.255.255.255
#

以下为RouterC置脚本: #
sysname RouterC
#
router id 1.1.1.3 /配置router id和loopback0地址一致/
#
radius scheme system
#
domain system
#
【验证】
RouterB分别和RouterA和RouterC建立iBGP邻接关系,但是RouterA和RouterB不建立iBGP邻接关系。
[RouterB]disp bgp peer
Peer AS-num Ver Queued-Tx Msg-Rx Msg-Tx Up/Down State
----------------------------------------------------------------------------
1.1.1.1 100 4 0 23 25 00:22:10 Established
1.1.1.3 100 4 0 7 8 00:05:36 Established

interface Ethernet0/0
ip address 40.1.1.1 255.255.255.0
#

interface Serial0/0
link-protocol ppp
ip address 30.1.1.2 255.255.255.252
#

interface NULL0
#

interface LoopBack0
ip address 1.1.1.3 255.255.255.255
#
#
bgp 100 /配置BGP,AS为100/
undo synchronization /配置非同步/
group in internal /配置组’in’/
peer in connect-interface LoopBack0
peer 1.1.1.2 group in /指定iBGP邻居/
#

ospf 1
area 0.0.0.0
network 1.1.1.3 0.0.0.0
network 30.1.1.0 0.0.0.3
#
user-interface con 0
user-interface vty 0 4
#
return
 

 

【提示】
1、 对于路由反射器的配置,只在反射器上配置有所差别,在cliet端是没有任何差别的。

 

bgp 100 /配置BGP,AS为100/
undo synchronization /配置非同步/
group in internal /配置组’in’/
peer in reflect-client /将对等体组作为路由反射器的客户/
peer in connect-interface LoopBack0
peer 1.1.1.1 group in /指定iBGP邻居/
peer 1.1.1.3 group in /指定iBGP邻居/
#

ospf 1
area 0.0.0.0
network 1.1.1.2 0.0.0.0
network 20.1.1.0 0.0.0.3
network 30.1.1.0 0.0.0.3
#

user-interface con 0
user-interface vty 0 4
#

return

TGAS:H3CAR28AR46BGP路由反射器
评论【共有0条评论】查看所有评论
称呼:(*)   邮箱:   QQ:   验证码: 看不清楚?点击刷新验证码